typescript 报错 TS1005 ; expected

2021年11月24日 阅读数:3
这篇文章主要向大家介绍typescript 报错 TS1005 ; expected,主要内容包括基础应用、实用技巧、原理机制等方面,希望对大家有所帮助。

今天遇到这个报错,html

error TS1005: '=' expected. import type { keyType } from './aa';node

以下图所示:typescript

package.json 中 编译 ts 的命令以下 "build-ts": "tsc -p tsconfig.build.json"npm

这个报错 主要是由于使用了下面这种语法json

import type { keyType } from './someType';

这个语法 import type仅仅导入, 这是 TypeScript 3.8 新增的属性segmentfault

关于 import type 想了解更多 能够看这俩:ui

https://segmentfault.com/a/1190000039800522
https://www.typescriptlang.org/docs/handbook/modules.html#importing-typescode

找到缘由是版本问题,那就按照网上的教程 npm install typecript@4.4.4 -g 安装了最新版本htm

可是还报错,后来在node_modules 下看到有个 typescript 一看版本是 3.7.2, 原来这个项目 自己是安装了 typescript的,blog

赶忙把该项目的typescript 更新到最新版本,问题解决, 以下图所示

总结:

这里其实涉及到了 node_modules 模块查找的问题, 当使用 tsc -p tsconfig.build.json 时, 首先会在 目录下的 node_modules 下中查找typsscript模块,
没有的话 再往上级,一直找到全局环境, 因此以前就是 先使用了 该项目中的 typescrip,致使了报错,虽然typescript 全局安装的版本是没问题, 可是 根本没使用到全局版本